SeedBot 1.3.4 Update from 2019-10-25 13:24 AWST to 2019-10-25 16:15 AWST

Scheduled maintenance SeedBot Discord Bot
2019-10-25 13:24 AWST · 2 hours, 50 minutes

Updates

Update

SeedBot is up and working as it should. Sorry for the inconvenience!

November 4, 2021 · 23:24 AWST
Update

It should be up soon!

November 4, 2021 · 23:24 AWST
Scheduled

SeedBot will be offline for a little bit due to the 1.3.4 Screen Share Update. Sorry!

November 4, 2021 · 23:24 AWST

← Back