Internet Down

Major incident DARiOX.club
1 day, 2 hours, 55 minutes

Updates

Resolved

Internet is back up. Major Outage

January 9, 2019 · 16:50 AWST
Monitoring

Internet is randomly down. Will be up in the next hour

January 8, 2019 · 13:56 AWST